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Introducción al TrueTTY 1.60

TrueTTY es un programa que recibe y transmite en los modos RTTY, ASCII-7, 

ASCII-8, AMTOR-FEC, BPSK31 y QPSK31 trabajando a través de la tarjeta de sonido ( Sound Blaster ). No necesita ningún hardward adicional ( TNC, Módem multimodo ... etc ) tu solo necesitas un Transceptor ( con VOX ) y un ordenador personal ( PC ).

Opcionalmente, tu puedes usar un simple circuito para controlar la conmutación entre TX y RX en el Transmisor o bien usar el VOX del propio equipo de radio.

El programa tiene muchos macros para TX. También puede cooperar con el libro de guardia AAlog Logger de RZ4AG.

Conexión de la Sound Blaster al Transceptor.

La salida de audio del Transceptor debería estar conectada con el “line in” o “Mic” de la tarjeta de sonido, y uno de los canales de salida de la tarjeta de sonido debe estar conectada a la entrada de Micro del Transceptor. El Transceptor debe trabajar en el modo SSB. La forma de generar la señal de RTTY es el modo AFSK. El programa puede generar una salida en FSK también. Esto puede ser útil si tu Transceptor no puede usar filtro estrecho en el paso de IF ( frecuencia intermedia) en el modo de SSB.

Es muy importante evitar saturar la entrada de micrófono o “line in” de la tarjeta de sonido y también la entrada de Mic del Transceptor. Usando atenuadores externos para reducir los niveles de salida de la tarjeta de sonido y Transceptor. Si tu sobrecargas o saturas el pre-amplificador de la tarjeta de sonido, tu no pueden eliminar la sobrecarga con los controles de  la tarjeta de sonido. Lo mismo ocurre para la entrada de micro del Transceptor.   

Para conmutar entre TX/RX  puedes usar el VOX de tu Transceptor o un simple circuito que va conectado entre un puerto COM o LPT del PC y la entrada de PTT del Transceptor ( el control del PTT vía LPT no funciona en Windows NT). El programa usa las salidas RTS o DTR en el puerto serie COM y usa la salida  D1 en el puerto paralelo LPT. Puedes ver abajo un esquema muy simple de control del PTT. Cuando estas usando el puerto serie el programa genera  la señal FSK sobre la salida TxD también. ( TxD es el pin 2 del conector DB25 o el pin 3 del conector DB9 ) seguramente, la señal FSK es generada solo en modo RTTY.  
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El programa puede trabajar con el interface para puerto paralelo de N6TR ( con las señales /INIT y /STROBE) Yo no recomiendo usarlo, por que los esquemas no son muy buenos.

La tarjeta de sonido debería soportar el modo "mono - 16 bits - 11025 Hz" la elección de una fuente de señal ( “line in” o entrada MIC)  y grabar  los niveles de salida realizados por el OS ( Control de volumen) Cuando tu seleccionas los niveles de entrada y salida asegúrate de nuevo que no saturas las entradas de la tarjeta de sonido y del Transceptor.

Volver al menú principal



Análisis del programa TrueTTY 1.60

El área de trabajo del programa esta dividido en unas pocas ventanas, los tamaños de las cuales pueden ser cambiadas por el usuario, pinchando sobre el borde de las ventanas.
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En la ventana superior hay un visualizador gráfico de señal ( línea azul) y un detector de señales débiles ( línea verde ). Las líneas rojas verticales indican las frecuencias de trabajo de los filtros en recepción. En el modo RTTY tu ves dos líneas rojas verticales, en PSK31 solo se ve una. Para cambiar el centro de la frecuencia de recepción, pincha con el ratón sobre la frecuencia deseada ( entre los dos picos en RTTY)

Las cortas líneas negras indican la frecuencia de TX, seguramente en el modo PSK31 tu veras solo una línea negra de TX. Para el centro de la frecuencia de TX, pincharas sobre la frecuencia deseada con el botón derecho de tu ratón. ( o con el botón izquierdo mientras mantengas pulsada la tecla "Control" ) Las frecuencias de TX y RX y los cambios son visualizados en la línea de estado del programa ( Abajo de la pantalla )
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Cuando el squelch esta activado la línea roja horizontal visualiza el umbral de corte del squelch. 

En la tercera ventana empezando desde arriba, esta el visualizador gráfico de la señal decodificada.

Los símbolos o caracteres recibidos son visualizados en la segunda ventana empezando desde arriba. Cuando el buffer de recepción a crecido hasta 20 kB, parte de los datos son movidos a un buffer invisible.

El botón AFC ( control automático de frecuencia ) Ajusta las líneas rojas ( trabajando en las frecuencias de RX ) acercándose a los picos de señal. Él numero de la izquierda junto al botón AFC determina los limites de trabajo en frecuencia ( un paso de ese valor es aproximadamente 5.4 Hz por 186 milisegundos ).

El botón SQL activa el squelch, él numero del lado izquierdo del botón SQL determina el umbral de corte del squelch.

La variación de velocidad y frecuencias son seleccionados por los  menús "Speed" y "Shift" respectivamente.   

El botón "TxAfc" ajusta la frecuencia central de TX a la frecuencia central de  RX.

El botón "Reverse/Normal" cambia de normal ("la marca" es tono alto) en reverse ("el espacio" es tono alto ) es el tono alto del modo RTTY. Este botón no modifica la polaridad de la señal de la salida de FSK del puerto serie. En modo QPSK es usado al seleccionar normal o invertido QPSK. En modo BPSK la posición del botón no tiene significado.

El botón "TX"  conmuta a TX el Transceptor. El programa transmite los caracteres introducidos en la ventana de abajo. Durante la transmisión los caracteres son enviados desde esa ventana a la segunda ventana empezando por abajo.

El botón "Pause"  para la transmisión de símbolos. El transmisor queda ON y continua la secuencia de  "Letter shift" y los símbolos son transmitidos.( en modo RTTY )

Trabajando en los modos (RTTY, ASCII-7, ASCII-8, AMTOR-FEC, BPSK31 y QPSK31)  esto es seleccionado en el menú "Mode".

La velocidad de la señal y el ancho de frecuencia son seleccionados en los menús "Speed" y "Shift" respectivamente. Coge esta consideración cuando tu selecionas los modos RTTY o AMTOR a través del menú "Mode", Velocidad y anchura serán restaurados a los valores por defecto 45 Baud/170 Hz y 100Baud/170 Hz respectivamente. 

Cuando el modo AMTOR-FEC es seleccionado, tu puedes decodificar transmisiones  SITOR-B y NAVTEX. Por que en realidad son el mismo modo. En este modo hay dos  opciones "Fast sync" y "Normal sync". Cuando esta seleccionado el "Fast sync" el programa puede sincronizar la recepción de señales más rápidas. Este modo no necesita unos símbolos especiales. Puede casualmente hacerse una incorrecta sincronización. 

Para recibir Broadcast FEC, el botón "Normal/Reverse" debe estar en la misma posición como en RTTY. Eso es "Normal" en USB y "Reverse" en LSB. Para recibir SELFEC, cambiar este botón a la otra posición y seleccionar la opción "Fast sync"

Si tu tarjeta de sonido puede trabajar en modo full-duplex, Esto es muy útil, se selecciona sobre el menú "Setup->Use Duplex Sound Card". En este caso tu puedes comprobar tu propia señal de transmisión. (Seguramente, Si tu Transceptor tiene la opción monitor "self-control capability").

Los botones "F1"..."F12" ( y "F1"..."F12" del teclado) son usados para transmitir los macros definidos con anterioridad. Tu puedes usar la tecla ESC y Ctrl-F1 ... Ctrl-F12,

Alt-F1 ... Alt-F12. La combinación Alt-F6 esta disponible solo a través del ratón. Los Macros están insertados dentro de "Input Windows" en el lugar indicado por el cursor. Abrir la ventana de edición de Macros, seleccionar el menú "edit macros". Tu puedes editar texto sobre los botones de los Macros. Tienen que contener unas secuencias especiales de caracteres llamadas: Macrosecuencias.


  

En particular, Las macrosecuencias pueden usar valores editados en los campos "Call", "Name", "RST", "Other"  situados sobre la ventana de tramas enviadas. El botón "Clear" borra o pone los valores por defecto de los campos antes citados. Los valores por defecto de: "CallOnClear", "RSTOnClear", "NameOnClear", "

OtherOnClear" se configuran en el fichero TRUETTY.INI
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El botón "OnTop" Pone el programa TrueTTY por encima de todas las ventanas.

La opción del menú "File->Clear Buffer" Borra los símbolos recibidos y el buffer invisible de RX, la opción "File->Save Buffer"  grava las dos partes del buffer de RX (invisible y visible) en un fichero.

El "File->Open Capture file" esta opción abre un fichero que captura los símbolos recibidos. Entonces los nuevos símbolos recibidos empiezan a ser escritos dentro de ese fichero.

El "File->Close Capture file" Este fichero cierran el fichero de captura. El estado del fichero de captura se puede ver en la línea de estado. La tecla rápida para abrir/cerrar el fichero de captura es Alt-L.

El menú  "Setup->PTT Interface"  es usado para seleccionar el interface que activa el PTT del Transceptor desde el PC.

Si la opción del menú "Setup->Tx At Keyboard" esta seleccionada, El transmisor cambia automáticamente a ON "TX" Cuando tu introduces algún carácter en la ventana de entradas. Si la opción "Setup->Rx At Free Buffer" esta seleccionada, el transmisor cambia a OFF "RX" automáticamente cuando deja de transmitir símbolos.

Mientras transmite "símbolos enviados" son borrados de la ventana de entradas y transferidos a la ventana de símbolos enviados. Cuando la opción "Setup->View->Show Sent Symbols In RX Window"  es cambiada a ON,  los símbolos enviados son vistos en la ventana de RX también.

La opción "Unshift On Space"  es cambiada a ON o OFF desde el menú "Setup->Unshift On Space". Cuando esta opción esta seleccionada, recibiendo "simbol shift" (Símbolos) cambian a "Letters" (Letras) después recibiendo "Space" o "Line Feed" symbol, siempre en los modos RTTY y AMTOR.

Conmutación manual de los símbolos RX puede ser hecha por el teclado.

Gris "*" o Alt-(gris "*") estos dibujos y  gris "-" o Alt-(gris "-") son letras.

Nota:  Gris"*" significa: es la tecla "*"  pero del teclado numérico.

La opción del menú "Setup->English Charset" , "Setup->Russian Charset" , "Setup->English/Russian Ext. Charset" , "Setup->Swedish Charset" seleccionan el alfabeto que es usado en los modos RTTY y AMTOR. La opción de menú "Setup->Extended Baudot" conmuta la tabla de códigos extendida ( con letras altas y bajas ) para estos modos.

La opción de menú "Setup->Backspace Handling" conmuta  a ON la opción "BACKSPACE"  (Borrar símbolos manualmente) en los modos  PSK y ASCII.

La apariencia de los símbolos recibidos en la ventana puede ser cambiada con los menús "Setup->Fonts and Colors". 

Algunas ventanas y paneles pueden ser ocultados a través de la opción del menú "Setup->View->...".

El programa puede transferir y recibir datos desde el programa de  Log AAlog ( V1.0.3  y versiones superiores ). Los datos son transferidos desde la ventana de RX y los campos editables "Call", "RST", "Name". Para transferir datos desde la ventana de RX hay que hacer un doble click sobre la palabra seleccionada por el ratón. Entonces seleccionas una opción de campo en el menú que aparece en pantalla. Cuando el dato son transferidos al campo correspondiente "Call" o "Name"  el campo del programa de Log también recibe el mismo dato. Los datos son transferidos desde el campo editable.

Selecciona la opción  salvar configuración del programa "Setup->Save Setup" Las nuevas configuraciones son grabadas en el fichero TRUETTY.INI . El programa busca este fichero en el directorio de trabajo. Así que tu puedes tener unos pocos ficheros INI para diferentes condiciones ( por ejemplo, uno para qso normales y otro para concursos). Crea unos pocos accesos rápidos a  TRUETTY.EXE con diferentes directorios de trabajo.

El numero visualizado en el campo "FrB" de la barra de estados, significa el numero de buffers libres para grabar una señal. Si este valor se reduce a 10 o menos la velocidad del ordenador no podrá ser mantenida. Intenta reducir él numero de programas abiertos simultáneamente en Windows o cambia de ordenador.  :-).

La mayoría de los botones de las pantallas tienen combinación de teclas rápidas.

El programa TrueTTY coopera con el programa Looger a través de ficheros INI y de mensajes Windows. Si tú eres el autor de un programa de Log y quieres ayudar a que nuestros programas trabajen juntos, escríbeme un e-mail para obtener información detallada.      

Respuestas ( ideas ) y deseos en todos los sentidos serán bien recibidos.      

Volver al menú principal




Análisis de las Macrosecuencias.

Las macrosecuencias empiezan con el siguiente carácter "~[" o "`[" y terminan con este otro carácter "]".

Las macrosecuencias que empiezan con los caracteres  "~["  son expandidas enseguida. Las macrosecuencias que empiezan con los caracteres "`[" son expandidas directamente delante de la transmisión.
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Aquí tienes la lista de Macrosecuencias:

       ~[mNN] o `[mNN] - Inserta una macro con el numero NN.

       ~[fFilename] o `[fFilename] - Inserta el contenido del fichero "Filename".

       ~[iField] o `[iField] - Inserta el valor de campo desde un fichero INI 

                          adicional. El  nombre de fichero "filename" y una sección

  del fichero INI son definidos por los parámetros "ExternIniFile"

  y "ExternIniSection" dentro del fichero TRUETTY.INI 



  Por defecto es usado la sección QSO del fichero AALOG.INI

    

  ( En el directorio Windows ) . Esas macrosecuencias pueden



  ser usadas estupendamente.



  Libro de guardia Aalog HAM Logger por Alexander Anipkin, RZ4AG

                          ( Ver la siguiente dirección de internet:   http://www.aalog.com ).

   ~[ec] o `[ec] - Inserta el valor editado en el campo "Call" (Indicativo).

   ~[er] o `[er]  - Inserta el valor editado en el campo "RST" (Reporte).

   ~[en] o `[en] - Inserta el valor editado en el campo "Name" (Nombre).

   ~[eo] o `[eo] - Inserta el valor editado en el campo "Other" (Información adicional).

   ~[lf] o `[lf] - Inserta una nueva línea (CR+LF).

   ~[tl] o `[tl] - Inserta la hora local.

   ~[tu] o `[tu]  - Inserta la hora UTC.

   ~[dl] o `[dl]  - Inserta la fecha local.

   ~[du] o `[du] - Inserta la fecha UTC.

   ~[cl]   -  Borra la ventana de entradas.   

   ~[crx]  - Borra el buffer de recepción.

   ~[csnt] - Borra la ventana de símbolos enviados.

   ~[tx]   - Conmuta a "TX" "TX on"  y conmuta a  "sin pausa" "pause off".

    `[rx]  -  Conmuta a "sin TX" "TX off". En lugar de esta secuencia es posible usar 

                 también el carácter  "}"

    `[pa] -  Conmuta a "pause" "pause on".

    Tu puedes usar las teclas rápidas Alt-] o Ctr-] para poner rápidamente la secuencia

   `[rx] en la ventana Input.

   `[cwrText] - Envía la secuencia "Text" en código morse y conmuta a RX.

   `[cwtText] - Envía la secuencia "Text" en código morse y continua con la transmisión

     en el modo normal.

   ~[cwrText] - Envía la secuencia "Text" en código morse y conmuta a RX.

    `[cwtText] - Envía la secuencia "Text" en código morse y continua con la transmisión

      en el modo normal.

     Es necesario usar el símbolo "_" en el lugar de un espacio dentro del texto de la

     secuencia "Text"

    El menú "Setup->Time Zone" define las diferencias entre la hora local y la hora

    UTC.  Cuando el "By OS" es seleccionado, el offset de la hora UTC es definido por

    Windows "Time Zone"
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Condiciones de distribución y registro del programa.

Tu puedes distribuir copias del programa siguiendo las siguientes dos condiciones:

    1. Lo puedes distribuir libre de costes. 

    2. Tu distribuyes el fichero original sin modificar.

El programa es distribuidos libremente. Tu puedes usarlo con propósito de evaluación durante 30 días. Si tu deseas continuar usando el programa después del periodo de evaluación, tu debes realizar el registro de pago al autor. La copia no registrada tiene algunas funciones deshabilitadas.

Hacer el pago on line a través de la tarjeta de crédito supone ( 35 $ ) cheques, dinero postal también. Arranca el programa TrueTTY y selecciona en el menú "Help->Register!" o también puedes arrancar tu Navegador de internet e ir a las siguientes direcciones URL:

    http://www.regsoft.net/purchase.php3?productid=16946
                                                                            (RegSoft.com ,conexión segura ) 

    http://www.regsoft.net/purchase_nonsecure.php3?productid=16946
                                                                            (RegSoft.com ,conexión no segura)

    https://secure.element5.com/register.html?productid=130183&language=English
                                                                            ( Servicio de registro) 

    https://www.regnow.com/softsell/nph-softsell.cgi?item=3043-2
                                                                            (servicio "Regístrate ahora" )

Tu puedes registrar el programa también vía correo postal. En este caso enviar 30 $ a:   

          Sergei Podstrigailo,

          P.B.13, Novosibirsk,

          630102, Russia .   

Y me dices el nombre o el indicativo al cual deberá ser registrado el programa, y una dirección de correo electrónico ( e-mail ) donde enviar la llave de registro(archivo).

Los miembros de la USSR pueden registrar TrueTTY por un precio especial. Ver el 

fichero LICENCE.TXT para mas detalles.
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